Upgrade PHP 5.4.30

Mengatasi Pesan Error Deprecated

PHP 5.3.x mungkin juga versi terbaru sudah tidak lagi mendukung function dibawah ini

  1. magic_quotes_runtime
  2. magic_quotes_sybase
  3. register_globals
  4. Komentar menggunakan ‘#’ di file .ini
  5. define_syslog_variables
  6. register_long_arrays
  7. safe_mode
  8. magic_quotes_gpc

Berikut cara mengatasi Deprecated dari Script PHP

  1. call_user_method() menjadi: call_user_func()
  2. call_user_method_array() menjadi: call_user_func_array()
  3. define_syslog_variables()
  4. split() menjadi: preg_split()
  5. session_register() menjadi: the $_SESSION superglobal
  6. session_unregister() menjadi:  $_SESSION superglobal
  7. session_is_registered() menjadi:  $_SESSION superglobal
  8. set_socket_blocking() menjadi: stream_set_blocking()
  9. spliti() menjadi: preg_split()
  10. ereg() menjadi: preg_match()
  11. ereg_replace() menjadi: preg_replace()
  12. eregi() menjadi: preg_match()
  13. eregi_replace() menjadi: preg_replace()
  14. set_magic_quotes_runtime() and its alias, magic_quotes_runtime()
  15. mysql_db_query() menjadi: mysql_select_db() dan mysql_query()
  16. mysql_escape_string() menjadi: mysql_real_escape_string()
  17. dl() functin ini sudah dihapus di PHP 5.3
  18. sql_regcase() DEPRECATED tanpa penganti?

Jika belum sempat melakukan perubahan script PHP bisa juga menghilangkan pesan error di browser dengan cara menabahkan error_reporting=E_ALL & ~E_NOTICE & ~E_DEPRECATED pada file php.ini. Jika menggunakan WHM terletak pada menu PHP Configuration Editor.

sumber : http://www.rahmatriyanto.com/mengatasi-pesa-error-deprecated.htm